Tags:

Viewing 6 posts - 1 through 6 (of 6 total)
Author
Posts
  • #10008

    Hello all,

    How does thumbnail generation work in Kiwitrees 3..0? (Yes, I know I should upgrade!)
    There does not seem to be an option on the media configuration page for automatic generation of thumbnails, so is this the default? If so, it doesn’t seem to be working because no thumbnail is available for an image I just uploaded (the image itself displays correctly). Is there a manual way of generating the thumbnail?

    James

  • #10009

    Hi James

    Yes, thumbnails are automatically generated.
    It is 95% certain your image is too “big” for your server to create a thumbnail. Note that “big” does not refer to the file size. To create a satisfactory thumbnail the original image, most likely a compressed file such as jpg/jpeg, needs to be uncompressed on your web server. A typical modern digital camera/smartphone image might explode to 30MBs when uncompressed, even though the file size might only be 2MB or less.
    You should have an error message to confirm this is the problem (administration > site administration > logs – filter for “errors”).

    Alternative causes can be linking to an external image or using a pdf file, neither of which can be converted to thumbnails. In these cases, you can include your own manually generated thumbnail copy at the same time you upload the original.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #10010

    Thanks for the reply Nigel.
    There was no corresponding error message in the log file.
    The file is a jpeg image, not a pdf file.

    I ended up producing a thumbnail image by hand (100px wide) and uploading it to the server. This worked fine, but I still don’t understand what prevented Kiwitrees from generating the thumbnail. The original image was only 175KB so even if it had been highly compressed I don’t see how uncompressing it would cause a problem.

    James

  • #10011

    If you send me the original file I’ll take a look and see what might cause it.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #10037

    I have tried that too. (was a batch running while I uploaded a media – it just happens sometimes). I made an edit of the image like changing type or folder and then it was created when I checked the ID which had the imagefile linked

    Regards,
    Jamie Jaconelli

    admin and owner of a user customized version of kiwitrees (contains 3 family trees)

  • #10038

    Thanks for your comment.
    After chasing around for some time, and some helpful suggestions from Nigel, It turned out that my problem was caused by having incorrect access permissions on the “thumbs” folder. Once I corrected the access permission on the directory everything worked fine. I was running Kiwitrees on my local machine for testing purposes so I can’t blame my web hosting service!

    Regards,

    James

Viewing 6 posts - 1 through 6 (of 6 total)
  • The topic ‘Thumbnail generation’ is closed to new replies.