Tags:

Viewing 9 posts - 1 through 9 (of 9 total)
Author
Posts
  • #8365

    Kiwitrees 3.3.0 and Php 5.6.30

    I have added birth, baptism, death, burial details to a person and in all instances the event tab does not close just displays the INDI id. I must close the tab manually, then refresh the INDI’s page tab for the new information to display.

    Penguins Are  Boss

    https://bootesgowland.kiwitrees.net

    Happy to be hosted by kiwitrees.net

  • #8366

    Yes, I know exactly the issue you are referring to, but sadly not the solution.

    I have seen it occasionally, but never consistently enough to trace. I “think” therefore it’s somehow related to the browser, rather than kiwitrees – or perhaps that’s just wishful thinking.

    Browsers can have different behaviors on open and close. I’ve also wondered if it’s related to the number in use, where each originated (the tab used to open each new one, or perhaps something with the browser cache.

    So if you can help narrow it down in any way that would be very useful.

    Does it an in different browsers, or different versions of a single browser? Does the number of tabs in use make a difference? Does clearing the browser cache help?

    I do know it’s not a new issue. I’ve seen it occasionally ever since the new edit tabs were introduced.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #8367

    This instance is using Chrome OS 57 with only 3 tabs open and ADDING a fact. When I EDIT an existing fact the tab closes and updates as normal.
    I can try (later) with Firefox and Linux Mint.
    I’ll do some more routine work and report back.
    pab

    Penguins Are  Boss

    https://bootesgowland.kiwitrees.net

    Happy to be hosted by kiwitrees.net

  • #8374

    Also in Chrome 58.0.3029.81, my normal browser and tested it also with Microsoft Edge 40.15063.0.0, which I normally don’t use.
    Cleared the cache and just with 2 or 3 tabs opened.
    Using PHP 7 and kiwitrees 3.3.0, It is on my website, but also on my local testversion.
    I had never seen this before the last upgrade.

  • #8377

    The same happens with Firefox and Linux Mint, so not a browser or PHP issue.

    Penguins Are  Boss

    https://bootesgowland.kiwitrees.net

    Happy to be hosted by kiwitrees.net

  • #8378

    Thanks for all the input. That has helped to narrow it down and enabled me to reliably reproduce the problem. I will transfer this to the Bugs section, and hopefully get a fix available asap.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #8469

    I have just added a new Probate record and the tab closed perfectly and the INDI page was updated …

    Penguins Are  Boss

    https://bootesgowland.kiwitrees.net

    Happy to be hosted by kiwitrees.net

  • #8473

    That’s an interesting clue. On further testing it (so far) seems to a problem ONLY with adding tags that are NOT included in the list of “Quick Add Facts” that are shown below the drop-down selector list.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #8482

    That’s an interesting clue. On further testing it (so far) seems to a problem ONLY with adding tags that are NOT included in the list of “Quick Add Facts” that are shown below the drop-down selector list.

    And that was exactly what I needed to know to find the bug 🙂

    Replace the file kiwitrees/includes/functions/functions_print.php with the one from the attached zip folder to fix the problem.

    Nigel
    My personal kiwitrees site is www.our-families.info
    1 user thanked author for this post.
Viewing 9 posts - 1 through 9 (of 9 total)
  • The topic ‘Tab not closing’ is closed to new replies.