• This topic has prefixes assigned
Viewing 10 posts - 1 through 10 (of 11 total)
Author
Posts
  • #13101

    I cant get access to my kiwitrees installation with SSL/https, all the other web programs on the server is running fine with SSL/https (joomla, wordpress and webtrees).
    The installation can be found here https://melfar.dk/kiwitrees.

    Best regards
    Ole H Madsen

  • #13102

    Ole

    This blog entry might help. There are details on the simple setting for it in kiwitrees near the end.

    Security, SSL and HTTPS – why should I care?

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #13108

    The problem seems to be my web host their ssl solution, it look like that the ssl connection is trying to use port 80 to https (see picture)

    Best regards
    Ole H Madsen

  • #13115

    Kiwitrees should be able to work OK with either port 80 or 443, (see kiwitrees/includes/session.php lines 180-203) so there might be something else unusual at the server.

    What does your phpinfo listing tell you about https settings (Administration > Site administration > Server information)?

    Look particularly at these settings:
    $_SERVER[‘REQUEST_SCHEME’]
    $_SERVER[‘HTTP_REFERER’]
    $_SERVER[‘HTTP_CF_VISITOR’]
    $_SERVER[‘HTTP_X_FORWARDED_PROTO’]
    $_SERVER[‘HTTPS’]

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #13126

    Settings http connection
    $_SERVER[‘REQUEST_SCHEME’] = http
    $_SERVER[‘HTTP_REFERER’] = http://melfar.dk/admin.php
    $_SERVER[‘HTTP_CF_VISITOR’] this line dosen’t exists
    $_SERVER[‘HTTP_X_FORWARDED_PROTO’]http
    $_SERVER[‘HTTPS’]this line dosen’t exists

    Settings https connection
    $_SERVER[‘REQUEST_SCHEME’] = https
    $_SERVER[‘HTTP_REFERER’] this line dosen’t exists
    $_SERVER[‘HTTP_CF_VISITOR’] this line dosen’t exists
    $_SERVER[‘HTTP_X_FORWARDED_PROTO’] = https
    $_SERVER[‘HTTPS’] = on

    and i have put an phpinfo page in the root folder melfar.dk/phpinfo.php

  • #13128

    Have you tried changing the “Website URL”, as described in the link I gave in my earlier reply?

    To explain further, the setting “”Website URL” can be found on Administration > Site administration > Site configuration. Set it to https://melfar.dk/ or whatever the correct URL for your https site should be (possibly https://melfar.dk/kiwitrees/)

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #13129

    The other thing you can try is a modification to the code, (that will have to be done again every time the software is updated).

    Here is the change, in the file kiwitrees/includes/session.php:

    https-fix

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #13133

    Problem solve, and many thanks for your help I manage to change the code, the other solution didn’t work i tried that a couple of days ago

    Best Regards
    Ole H Madsen

  • #13134

    Ole

    Could you try replacing the file you just modified (kiwitrees/includes/session.php) with the one in the attached zip folder.

    I hope this might also solve your problem, but in a way that can be part of standard code, so you do not need to make the change at every upgrade. I am also testing it on servers that use the more common port ‘443’ to be sure they still work normally. So far it seems to be OK.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #13155

    New the new file is also solve the problem

    Best regards
    Ole H Madsen

Viewing 10 posts - 1 through 10 (of 11 total)
  • You must be logged in to reply to this topic.