Viewing 10 posts - 1 through 10 (of 30 total)
Author
Posts
  • #11631

    My cousin has sent me family photos. And I’ve got ones saved. know I could attach to record(s) but other alternate/addition I thought was photo album. This would save “bulking up” an individual record.

    How far-fetched is this idea, which is not anything near what kiwitrees was built as: create family tree that could be switched to. Create record for the picture(s). No links between trees would be used except via default switch.

    It’s outside-the-box but can’t think of how to link from kiwitrees to an external photo album (not an online) Not even sure if the album software still exists. I know one did stop development, will have to see about the other.

    -----
    [updated: 06 Mar 2021]
    MacOS: 10.15.7  (Catalina)
    Safari  14.0.03;  Firefox85.0.2
    PHP 7.4 FastCGI

    Alter-Drukarsh connections... 3.3.8 <private>
    The Royals 3.3.8<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.8 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #11632

    Yes, it’s called the “gallery” module. All you need to do is enable it in Admin > Modules.

    See https://www.our-families.info/module.php?mod=gallery&mod_action=show&gallery_id=898 for a working example.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #11633

    I enabled the Gallery. Checked your family’s link and see the text and outline of where the image would be.

    That’s what I’m not being able to do. I added a folder in my installation “galleryImages”. But when I click Edit beside the Gallery I created and see Source, the dropdown doesn’t let me select it.

    -----
    [updated: 06 Mar 2021]
    MacOS: 10.15.7  (Catalina)
    Safari  14.0.03;  Firefox85.0.2
    PHP 7.4 FastCGI

    Alter-Drukarsh connections... 3.3.8 <private>
    The Royals 3.3.8<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.8 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #11634

    I’m not at home today, but there’s an FAQ link on the gallery admin page that might help.

    Are there any pictures in the folder. Creating the folder is something normally done through the “add media” operation.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #11635

    … and see the text and outline of where the image would be.

    This puzzled me – until I remembered I’d been using my own site to test some of your media privacy issues. I’d left media set to “Show to managers”!

    Take another look for better examples.
    https://www.our-families.info/module.php?mod=gallery&mod_action=show&gallery_id=898

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #11636

    Ha, ha. I assumed they were of people so wasn’t surprised they didn’t display. The photos are quite something. And noted especially the ones so beautifully framed. Will play around with setting one up.

    -----
    [updated: 06 Mar 2021]
    MacOS: 10.15.7  (Catalina)
    Safari  14.0.03;  Firefox85.0.2
    PHP 7.4 FastCGI

    Alter-Drukarsh connections... 3.3.8 <private>
    The Royals 3.3.8<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.8 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #11637

    The FAQ link doesn’t give much help. Ments local media items in a folder which is what I have. But, no method to link to it. No mention of how to actually get images or files into the gallery.

    -----
    [updated: 06 Mar 2021]
    MacOS: 10.15.7  (Catalina)
    Safari  14.0.03;  Firefox85.0.2
    PHP 7.4 FastCGI

    Alter-Drukarsh connections... 3.3.8 <private>
    The Royals 3.3.8<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.8 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #11638

    The FAQ link doesn’t give much help. Ments local media items in a folder which is what I have. But, no method to link to it. No mention of how to actually get images or files into the gallery.

    See section 1 – Upload images, under “Set up”. Follow it to the letter. Especially item c.

    Also read and understand this earlier paragraph. It is very important :

    To operate the module requires that the (local) media items you want to display are stored in a single folder within kiwitrees’ media storage structure. It can be any folder or sub-folder, at any level, but only a single complete folder can be displayed. There is no option to select specific items only.

    Note that “local” means local to (within) kiwitrees on your web server, as opposed to stored on some other server or computer somewhere.

    Just now looking at the text in that para c. just mentioned, perhaps I should expand further on that for you:

    Once you have uploaded the media, find it / them in Manage Media, by clicking on the “Unused media” option. Then click “Create” and fill in what ever (if anything) you want there before clicking “save”.

    Only once that is done for at least one picture will you find the new folder displayed in the select list.

    One final thought – uploading via “Upload media files” in admin, is only as a convenience if there are not many of them. Otherwise you can simply FTP them all straight into your new folder in one go. BUT – you must still follow the instructions in para c. of the FAQ, and expanded just above here.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #11639

    I flunked. Followed your instructions. Honest, I’m quite sure I did.

    I used the “Upload media” to see where it would put the folder. It nested 3 in:
    media/subfolder/subfolder. Tried variations including FTP but when I finally saw them in Manage Media and under the “Unused” section, left them.

    The first image I did NOT link to the person. The second I did. No reason other than to see difference.

    Went to Edit the Gallery (either from a record or in Admin Panel). Added something to Summary. In the tab Galleries, created a Gallery. Selected the location of the images.

    Went to a record and selected Gallery (NOTE: Gallery plural is Galleries, not Gallery). I see the Summary. Nothing else.

    The setup is in my Rebbes site. Two images have been uploaded, G1.png and G2.png. They both have Titles and Notes added from the Manage Media section.

    PS: The Galleria theme website is no more. I got server not found.

    -----
    [updated: 06 Mar 2021]
    MacOS: 10.15.7  (Catalina)
    Safari  14.0.03;  Firefox85.0.2
    PHP 7.4 FastCGI

    Alter-Drukarsh connections... 3.3.8 <private>
    The Royals 3.3.8<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.8 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #11640

    OK, I have looked at your site in detail, using the login details you provided before. Actually there isn’t a great deal wrong. Just a couple of mis-understandings. However, I can’t easily see everything as I don’t have access to your server itself.

    Just in case there is a problem I wasn’t aware of, I would like to try setting a gallery up from scratch myself, on your system. I shouldn’t need any access to the server for that. But first, it would help to ensure there are no introduced errors from your earlier start with gallery. Can you, on your web server, in the /data/ folder, delete all / any subfolders with the name “rebesGallery” and everything they contain.

    Let me know when that is done. I will then try a “from basics” gallery set up myself and see if any problems arise that shouldn’t, and what they are. I’ll use random images I have here, and once that works, you can edit the gallery and the images etc to suit your actual needs.

    Nigel
    My personal kiwitrees site is www.our-families.info
Viewing 10 posts - 1 through 10 (of 30 total)
  • You must be logged in to reply to this topic.