Tags:

Viewing 10 posts - 1 through 10 (of 12 total)
Author
Posts
  • #3495

    I uploaded a PDF, for an event. When I switch to Album view, it doesn’t appear as one of the files. Perhaps this is as intended?

    -----
    [updated: 06 Aug 2021]
    MacOS: 10.15.7  (Catalina)
    Safari   14.0.3;  Firefox 9.0.2
    PHP 7.4.5 FastCGI

    Alter-Drukarsh connections... 3.3.9 <private>
    The Royals 3.3.9<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.9 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #3497

    No, certainly not intended.

    Is you album configured to display PDF files? Admin > modules > album.

    I don’t understand the image you attached. Where is it from? What is it supposed to be? Perhaps more of the page would help.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #3498

    Oh, should have said that’s from the Admin Media but it’s know there. But not in the record > Album tab.

    The file is Format: PDF; Type: Document my config in Modules > Album doesn’t have Document.

    -----
    [updated: 06 Aug 2021]
    MacOS: 10.15.7  (Catalina)
    Safari   14.0.3;  Firefox 9.0.2
    PHP 7.4.5 FastCGI

    Alter-Drukarsh connections... 3.3.9 <private>
    The Royals 3.3.9<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.9 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #3499

    my config in Modules > Album doesn’t have Document.

    That doesn’t make sense. Document is a standard media type so should always be there. Are you confusing “type” with “group”?
    Can you post image of your config page.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #3500

    my config in Modules > Album doesn’t have Document.

    That doesn’t make sense. Document is a standard media type so should always be there. Are you confusing “type” with “group”?
    Can you post image of your config page.

    Four groups shown, the maximum that have “preloaded” headings across.

    -----
    [updated: 06 Aug 2021]
    MacOS: 10.15.7  (Catalina)
    Safari   14.0.3;  Firefox 9.0.2
    PHP 7.4.5 FastCGI

    Alter-Drukarsh connections... 3.3.9 <private>
    The Royals 3.3.9<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.9 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #3502

    Compare your image with the one at this FAQ page: https://kiwitrees.net/faqs/modules-faqs/album/ (It’s one of the three pictures that scroll across the top).

    Its not the ‘groups” across the table that matter. They can be whatever you want, and there can be as many or as few of them as you choose.

    Your problem is that you have a number of media ‘types’ including document missing from the column of types on the left. That list should be 17 items and should never change:
    Audio
    Book
    Card
    Certificate
    Coat of Arms
    Document
    Electronic
    Magazine
    Manuscript
    Map
    Microfiche
    Microfilm
    Newspaper
    Other
    Painting
    Photo
    Tombstone
    Video

    You are missing a number of them. They are hard-coded into kiwitrees (and webtrees) so I can only think of a few ways they might be missing:

    1. They exist in the file /library/WT/Gedcom/Tag.php twice at the very end of the file. Has this been manually modified in some way?
    2. They are translatable texts, so is your language file missing these? Although normally that would simply result in them appearing in the default en_US language.
    3. Have you used a custom language file to force items such as “document’ to translate as something else?
    Nigel
    My personal kiwitrees site is www.our-families.info
  • #3503

    file /library/WT/Gedcom/Tag.php >>> I never knew this file existed let alone how to modify. And, wouldn’t do such without asking as I know nothing about PHP.

    //////////////////////////////////////////////////////////////////////////////
    // Definitions for Object, File, Format, Types
    //////////////////////////////////////////////////////////////////////////////

    private static $OBJE_FILE_FORM_TYPE=array(
    ‘audio’, ‘book’, ‘card’, ‘certificate’, ‘coat’, ‘document’, ‘electronic’,
    ‘fiche’, ‘film’, ‘magazine’, ‘manuscript’, ‘map’, ‘newspaper’, ‘photo’,
    ‘tombstone’, ‘video’, ‘painting’, ‘other’,
    );
    // Translate the value for 1 FILE/2 FORM/3 TYPE
    public static function getFileFormTypeValue($type) {
    switch (strtolower($type)) {
    case ‘audio’: return WT_I18N::translate(‘Audio’);
    case ‘book’: return WT_I18N::translate(‘Book’);
    case ‘card’: return WT_I18N::translate(‘Card’);
    case ‘certificate’: return WT_I18N::translate(‘Certificate’);
    case ‘coat’: return WT_I18N::translate(‘Coat of Arms’);
    case ‘document’: return WT_I18N::translate(‘Document’);
    case ‘electronic’: return WT_I18N::translate(‘Electronic’);
    case ‘fiche’: return WT_I18N::translate(‘Microfiche’);
    case ‘film’: return WT_I18N::translate(‘Microfilm’);
    case ‘magazine’: return WT_I18N::translate(‘Magazine’);
    case ‘manuscript’: return WT_I18N::translate(‘Manuscript’);
    case ‘map’: return WT_I18N::translate(‘Map’);
    case ‘newspaper’: return WT_I18N::translate(‘Newspaper’);
    case ‘photo’: return WT_I18N::translate(‘Photo’);
    case ‘tombstone’: return WT_I18N::translate(‘Tombstone’);
    case ‘video’: return WT_I18N::translate(‘Video’);
    case ‘painting’: return WT_I18N::translate(‘Painting’);
    default: return WT_I18N::translate(‘Other’);
    }
    }

    // A list of all possible values for 1 FILE/2 FORM/3 TYPE
    public static function getFileFormTypes() {
    $values=array();
    foreach (self::$OBJE_FILE_FORM_TYPE as $type) {
    $values[$type]=self::getFileFormTypeValue($type);
    }
    uasort($values, ‘utf8_strcasecmp’);
    return $values;
    }
    }
    They are translatable texts, so is your language file missing these? Although normally that would simply result in them appearing in the default en_US language.
    I only have the default files for languages, paired down to
    en_GB.mo; en_US.mo; fr.mo; he.mo

    Have you used a custom language file to force items such as “document’ to translate as something else?
    as above – never touched.

    -----
    [updated: 06 Aug 2021]
    MacOS: 10.15.7  (Catalina)
    Safari   14.0.3;  Firefox 9.0.2
    PHP 7.4.5 FastCGI

    Alter-Drukarsh connections... 3.3.9 <private>
    The Royals 3.3.9<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.9 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #3504

    I just edited an image and looked at the TYPE drop down. It’s got all the entries, per image.

    -----
    [updated: 06 Aug 2021]
    MacOS: 10.15.7  (Catalina)
    Safari   14.0.3;  Firefox 9.0.2
    PHP 7.4.5 FastCGI

    Alter-Drukarsh connections... 3.3.9 <private>
    The Royals 3.3.9<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.9 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #3506

    That’s very strange. Everything appears normal there.

    Another remote possibility. In the folder /modules_v3/ do you have a sub-folder called ‘lightbox’? If so, try deleting it. It shouldn’t be there, and contains the old album tab code which might be conflicting with the new.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #3507

    That’s very strange. Everything appears normal there.

    Another remote possibility. In the folder /modules_v3/ do you have a sub-folder called ‘lightbox’? If so, try deleting it. It shouldn’t be there, and contains the old album tab code which might be conflicting with the new.

    No lightbox. I remember the name from way back but never used it. The image I just uploaded I changed the TYPE to microfilm (on dropdown/not album admin), and it didn’t appear on the Album tab. Changed to microfiche (on dropdown/on album admin) and it appeared.

    Because I always used Media, not Album, never realized what it was all about. So, guess this exercise helped me learn 🙂 Now when I get the “missing items” I see how they can be used.

    -----
    [updated: 06 Aug 2021]
    MacOS: 10.15.7  (Catalina)
    Safari   14.0.3;  Firefox 9.0.2
    PHP 7.4.5 FastCGI

    Alter-Drukarsh connections... 3.3.9 <private>
    The Royals 3.3.9<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.9 <royals.rbcsolutions.ca/index.php?ged=rebbes>

Viewing 10 posts - 1 through 10 (of 12 total)
  • The topic ‘PDF 'missing' in Album tab view’ is closed to new replies.