Viewing 10 posts - 1 through 10 (of 10 total)
Author
Posts
  • #5284

    I have small problem, each time i have make changes to a individual or a family, i need to reload the page with Ctrl + F5 to see the new changes it also happen on the module page, anything i can do to fix that problem ?
    I use Firefox
    and the server is running Kiwitrees 3.1.1 with PHP Version 5.6.12
    Best Regards
    Ole H Madsen

  • #5285

    Ole, that must be annoying.

    I have tested a similar installation, using kiwitrees 3.1.1, Firefox 40.0.3 and PHP 5.6.9, and cannot reproduce this issue.

    So we need to eliminate all possible causes:
    1 – We have both used kiwitrees 3.1.1, so that is unlikely to be the cause. Also, no other user has reported this.
    2 – We have both used Firefox. But what version of FF do you have? (In Firefox go to Help > About Firefox)
    3 – We have a very small difference in PHP version. I have looked at the changes between PHP 5.6.9 and 5.6.12 and can see no change that would cause this. Perhaps someone else who has 5.6.12 could check this for us.
    4 – What operating system are you using, PC or MAC, Windows 7/8/9/10 etc?
    4 – Have you checked in your logs to see if there are any messages? Check the kiwitrees logs (Administration > Site administration > Logs…Type = error). Also check your web server logs if you have access to them. If no access contact your web host and ask them to check for errors around the time you think this happened.
    5 – Try testing the same actions using a different browser, and if possible a completely different computer.

    Finally – I might be able to see what is happening if I can access your site with full admin privileges. Is that possible? You can email details to me ([email protected]).

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #5286

    Hi Nigel
    This morning i have been trying to see if the problem occur on other computers/browsers, and it occur on all the computers/browsers i was trying.
    The setup was as stated below.
    Desktop pc running Linux Mint 17.2 with Firefox 40.0.03
    Desktop pc running Linux Mint 17.2 with Chromium 44.0.2403.89
    Laptop running Windows 10 pro with Firefox 40.0.3
    Laptop running Windows 10 pro with Google Chrome 44.0.2403.157 m

    I have this error in the kiwitrees log file ERROR 8: Array to string conversion; 0 Error occurred on in function array_unique 1 called from line 358 of file calendar.php but i dont think it has something to do with my problem.

    the server log file dose not report about any error

    I have sent you an email with login information

    Best Regards
    Ole H Madsen

  • #5287

    I have this error in the kiwitrees log file ERROR 8: Array to string conversion; 0 Error occurred on in function array_unique 1 called from line 358 of file calendar.php but i dont think it has something to do with my problem.

    You are right. It is not related to your edit problem.

    But it is easy to fix. There is a replacement file attached to this forum topic:

    https://kiwitrees.net/forums/topic/calendar-php/

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #5302

    At my historic installation Im using 5.6.12. And I can not reproduce this issue either. Also using the kiwi theme.

    Regards,
    Jamie Jaconelli

    admin and owner of a user customized version of kiwitrees (contains 3 family trees)

  • #5303

    Sorry, I should have posted the explanation after reviewing Ole’s installation.

    We found the problem is related to the web server his web host uses. It is “LiteSpeed”. Similar to Apache and Nginx in many ways, but with some problems. There is a review of it here:
    (http://www.crucial.com.au/blog/2015/03/26/web-server-battle-apache-vs-litespeed/)

    It is not very favourable. But more important, I have no way to test kiwitrees on this server (and no interest in doing so). I have recommended that Ole change to a different installation when he can. I cannot suggest any other solution.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #5304

    No worries – Im just happy you figure out how the problem occurred!
    What would happend if Ole change the user setup ? Meaning not having automatic changes accepted? (ikke automatiske godkendelser i din bruger setup)

    Regards,
    Jamie Jaconelli

    admin and owner of a user customized version of kiwitrees (contains 3 family trees)

  • #5305

    What would happend if Ole change the user setup ? Meaning not having automatic changes accepted?

    it makes no difference. The problem is bigger than just that. For example the drop-down login box (kiwitrees theme) will not accept any entries!

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #5306

    Oh Zeus – Not good! 🙁

    I see your point!

    Thank you!

    Regards,
    Jamie Jaconelli

    admin and owner of a user customized version of kiwitrees (contains 3 family trees)

  • #5307

    I have trying to host Kiwitrees on one of my own computers the last couples of days http://www.vends-herred.dk and on my own server it runs without any problem. I will contact my Web Hosting provider to see if they have a solution.
    Best Regards
    Ole H Madsen

Viewing 10 posts - 1 through 10 (of 10 total)
  • The topic ‘Need to reload after editing’ is closed to new replies.