Viewing 3 posts - 1 through 3 (of 3 total)
Author
Posts
  • #4786

    I thought I would start a topic to capture any issues anyone finds using php 5.6. If you have what you think might be a 5.6 issue add it here. I will investigate each one, and if it’s not 5.6 related I’ll move the issue to another topic.

    To date we have had feedback from two users:

    1 – reporting that kiwitrees is working fine (PHP updated on an existing kiwitrees (3.0.0) installation)
    2 – reporting a number of Zend library errors.

    1 is obviously good news, but 2 is hard to confirm.

    Now that ver. 3.1.0 is released I have started my own testing. So far I have not seen any Zend errors myself.

    I have identified some issues setting up a new installation of kiwitrees though. They are already fixed ready for a 3.1.1 release. I will not release that yet though. Better to wait for more testing. It will not effect any existing users, and as we require membership of kiwitrees.net for new users I will know when any of those are likely to need this.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #4788

    Zend issues

    I may have found the problem. I have been able to reproduce this error message:

    Deprecated: iconv_set_encoding[]: Use of iconv.internal_encoding is deprecated in C:\xampp\htdocs\kiwitrees\library\Zend\Locale\Format.php on line 313

    Not sure if that is the one previously seen, but it will be easy enough to fix, I think.

    EDIT (22/07/2015): Zend issues fixed.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #4796

    I just set my “royalty” site to 5.6 Fast CGI. Not sure if I’ll know what’s PHP related but will see.

    ----- [updated: 06 Feb 2022] MacOS: 10.15.7  (Catalina) Safari   14.1.2;  Firefox 96.0 PHP 8.0 FastCGI; mySQL 5.x

    Alter-Drukarsh Connections 3.3.10b/the Garelicks <family members only>

    The Royals | The Kennedys |The Gerrer Rabbis 3.3.10b <.rbcsolutions.ca>

Viewing 3 posts - 1 through 3 (of 3 total)
  • The topic ‘kiwitrees compatability with php 5.6’ is closed to new replies.