Tags:

Viewing 10 posts - 1 through 10 (of 13 total)
Author
Posts
  • #3516

    Nothing to do with kiwiTrees: Just went through a painful process of dates with an Excel spreadsheet into FileMaker Pro. Web data master source was combo of Canadian date & time. Separation still left me with Canadian date. Part of the work had me changing my OS date format to ISO then fudging others. The major concern was all my other apps that support American dates (MM/DD/YYYY) so reverted OS back. Proves the theory of GIGO: garbage in, garbage out.

    While I was at it, I tested my kiwiTrees site and in fact, the ISO date isn’t recognized. It took 2014 01 25 and formatted to 25 Jan 2014 in edit mode and January 25, 2014 in display mode. We had recent discussion about dates but ISO is a standard that would avoid many problems incurred with country boundaries. YYYY MM DD (with slashes, dashes or whatever you want in-between each (usually slashes).

    -----
    [updated: 06 Aug 2021]
    MacOS: 10.15.7  (Catalina)
    Safari   14.0.3;  Firefox 9.0.2
    PHP 7.4.5 FastCGI

    Alter-Drukarsh connections... 3.3.9 <private>
    The Royals 3.3.9<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.9 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #3517

    While I was at it, I tested my kiwiTrees site and in fact, the ISO date isn’t recognized. It took 2014 01 25 and formatted to 25 Jan 2014 in edit mode and January 25, 2014 in display mode.

    I must be missing something in the translation from Canadian to English 🙂 It is most certainly “recognized”. Your own words prove that. It is accepted and converted to the required genealogical standards perfectly correctly.

    If the ISO date is 2014 01 25, and kiwitrees displays it as 25 Jan 2014 in edit mode and January 25, 2014 in display mode then it is working exactly as required.

    There are two issues:
    1 – The “edit mode” you refer to is in fact the GEDCOM standard. That cannot be changed for as long as we continue to conform to the standard (which is likely to be at least as long as I live).

    2 – The “display mode” is set by a language variable.
    For the US it is currently set to January 25, 2014
    For GB and Canada it is currently set to 25 January 2014
    For French it is Janvier. 25 2014
    Other languages have their own versions.

    As a language variable you are free, via a custom language file, to set the display to whatever you prefer. I have in the past chosen to use “Jan 25, 2014” on my own site. You could certainly use ISO for display if you wish.

    One other small point. “2014 01 25” is not a valid ISO date. It should be either 2014-01-25 or 20140125 (ref: http://en.wikipedia.org/wiki/ISO_8601)

    The problem with it for genealogical purposes is that it is based on a modified form of the Gregorian calendar (using a different base year) which makes it difficult for other non-Gregorian calendars such as early French, or Hjiri, Jalali, Jewish calendars etc..

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #3518

    I would have thought that input 2014-01-21 would display as 2014 January 21 by default unless custom file overrides. I flunked doing the custom file way back with PGV and never tried again. Would like to modify to 2014 Jan 25.

    I would have assumed that ISO applying to Gregorian would have no bearing on any other calendar because you select the calendars separately. So, my using Gregorian ISO date wouldn’t impact using the Hebrew calendar I have turned on too. Does the Hebrew calendar version follow whatever rules dictate for display of Hebrew dates? (Hebrew for example, substitute the others)

    The “display mode” is set by a language variable>>> So I discovered that it’s not reading my OS date when I did modify OS. I was worried it would, after all, not had reason to play with my OS date since I set in 4 years ago. But, OpenOffice does use it or at least I think it does.

    Would appreciate knowing how to change my date format, SVP.

    -----
    [updated: 06 Aug 2021]
    MacOS: 10.15.7  (Catalina)
    Safari   14.0.3;  Firefox 9.0.2
    PHP 7.4.5 FastCGI

    Alter-Drukarsh connections... 3.3.9 <private>
    The Royals 3.3.9<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.9 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #3519

    I would have thought that input 2014-01-21 would display as 2014 January 21 by default unless custom file overrides.

    Definitely not. As I said, the display setting for the US language file is “F j, Y” which means “January 21, 2014”

    I would have assumed that ISO applying to Gregorian would have no bearing on any other calendar because you select the calendars separately. So, my using Gregorian ISO date wouldn’t impact using the Hebrew calendar I have turned on too. Does the Hebrew calendar version follow whatever rules dictate for display of Hebrew dates? (Hebrew for example, substitute the others)

    That is correct, But there must still always be translation from GEDCOM format (for display purposes) to each ther calendar. SO we would have to write one for GEDCOM to ISO. That’s easy for post 1875 dates (that’s the base year for ISO) but far messier when you get to earlier dates, especially BC dates.

    Would appreciate knowing how to change my date format, SVP.

    Happy to help with that. But you need to confirm, do you mean you want to display:
    2014 Jan 09
    or
    2014 Jan 9

    The code for 9 vs 09 is different.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #3520

    Happy to help with that. But you need to confirm, do you mean you want to display:
    2014 Jan 09
    or
    2014 Jan 9

    The code for 9 vs 09 is different.

    I’d like 2014 Jan 09 please.

    US language file is “F j, Y” is probably why I never figured out the format. I’m accustom to customizing with using D or M or Y variations.

    -----
    [updated: 06 Aug 2021]
    MacOS: 10.15.7  (Catalina)
    Safari   14.0.3;  Firefox 9.0.2
    PHP 7.4.5 FastCGI

    Alter-Drukarsh connections... 3.3.9 <private>
    The Royals 3.3.9<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.9 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #3521

    OK, great. Just follow these steps very carefully.

    • Unzip the attached file to get “en_US.php”.
    • Create a new folder as a subfolder of kiwitrees/data/ on your server, call it “language”, and put this file in there.

      [So it is at: “kiwitrees/data/language/en_US.php”]

    • In kiwitrees go to Administration > Clean up data folder.
    • Tick “cache” and then ‘Delete”.
    • Now go back to the front end of your site [any page as long as it has dates on it] and refresh the page.
    • Your should now see dates in the form “2014 Jan 09”

    US language file is “F j, Y” is probably why I never figured out the format. I’m accustom to customizing with using D or M or Y variations.

    D, M, Y are valid, but there are MANY more options. For what you need it’s actually “Y M d”. The full list of options is at http://php.net/manual/en/function.date.php

    You can modify the attached file to display any of those variables. Just make sure you only change the second part of the array, not the first, and always leave the “%” signs in place. Once you change the file repeat the “delete cache” step described above every time, otherwise you’ll need to wait at leasta couple of hours before it clears itself automatically. All language strings are held in cache to speed up the system.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #3555

    kiwi,
    Finally had time to install the attached. Followed steps carefully. Viewed my own page and date format has not changed. It appears as January 01, 2014.

    -----
    [updated: 06 Aug 2021]
    MacOS: 10.15.7  (Catalina)
    Safari   14.0.3;  Firefox 9.0.2
    PHP 7.4.5 FastCGI

    Alter-Drukarsh connections... 3.3.9 <private>
    The Royals 3.3.9<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.9 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #3556

    Repeat this part:

    In kiwitrees go to Administration > Clean up data folder.
    Tick “cache” and then ‘Delete”.

    Now go to your own page again and click your browser’s ‘refresh’ button.

    Caching is the only thing that will stop (actually delay) this from working, EXCEPT if you put the file in the wrong folder, or called that folder “data/languages” instead of “data/language”.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #3557

    Cache was emptied twice. Folder is data/language/…

    -----
    [updated: 06 Aug 2021]
    MacOS: 10.15.7  (Catalina)
    Safari   14.0.3;  Firefox 9.0.2
    PHP 7.4.5 FastCGI

    Alter-Drukarsh connections... 3.3.9 <private>
    The Royals 3.3.9<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.9 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #3558

    Leave it a couple of hours in case you have some other caching happening.

    After that there is nothing I can do without access to the site. I have confirmed it works perfectly on my site.

    Nigel
    My personal kiwitrees site is www.our-families.info
Viewing 10 posts - 1 through 10 (of 13 total)
  • The topic ‘ISO date format’ is closed to new replies.