Viewing 10 posts - 1 through 10 (of 12 total)
Author
Posts
  • #5427

    DataTables warning: table id=media-table-8cbc11957151b692355cdfe5f02102db – Invalid JSON response. For more information about this error, please see http://datatables.net/tn/1

    Have just visited my personal site after quite a long hiatus. Saw no images loaded so investigated. Had the above as pop up error. I visited the mentioned URL in Safari (Mac) but didn’t understand the instructions.

    The admin > media page had page full of this error.
    Deprecated: iconv_set_encoding(): Use of iconv.internal_encoding is deprecated in /home/user/alterfamily.woodengems.com/xxx/library/Zend/Locale/Format.php on line 313 (each repeat of error shows different line number

    Realized I was at 3.1.0. Am doing update to 3.1.1. Will that fix the problem?

    -----
    [updated: 11 Jun 2021]
    MacOS: 10.15.7  (Catalina)
    Safari   14.0.3;  Firefox 89.0
    PHP 7.4 FastCGI

    Alter-Drukarsh connections... 3.3.8 <private>
    The Royals 3.3.8<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.8 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #5428

    Realized I was at 3.1.0. Am doing update to 3.1.1. Will that fix the problem?

    I think so, but too long since 3.1.1 was released so can’t say for sure. Let me know after you’ve upgraded and I’ll look into it if not fixed.

    (ps – please keep up to date – it really does help with bug tracing 🙂 )

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #5429

    I was quite surprised that I wasn’t current.

    Just in midst of transferring files. Encouraged that you think it may help!

    -----
    [updated: 11 Jun 2021]
    MacOS: 10.15.7  (Catalina)
    Safari   14.0.3;  Firefox 89.0
    PHP 7.4 FastCGI

    Alter-Drukarsh connections... 3.3.8 <private>
    The Royals 3.3.8<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.8 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #5430

    The update didn’t work. Now I can’t even log in. Attempted to use the offline.txt file to block the error messages but that didn’t take.

    -----
    [updated: 11 Jun 2021]
    MacOS: 10.15.7  (Catalina)
    Safari   14.0.3;  Firefox 89.0
    PHP 7.4 FastCGI

    Alter-Drukarsh connections... 3.3.8 <private>
    The Royals 3.3.8<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.8 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #5431

    Sounds like your upgrade is incomplete, probably resulting in a mix of old, new, and corrupt files.

    I would recommend deleting all except the /data folder and upload a completely fresh copy. Providing you leave /data alone no harm can be caused to your database or media files.

    What FTP software do you use? There is one commonly used product that regularly causes issues like this. Sorry but I can’t recall its name just now.

    If you would prefer me to do it, just email me the necessary FTP access details. I will be able to look at it in about 24 hours.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #5432

    There’s two FTP programs I use: Transmit and FIleZilla. The latter lets me have better view of what’s happening. I used it for my Royals site and it works okay.
    Did clean install. Same errors.

    -----
    [updated: 11 Jun 2021]
    MacOS: 10.15.7  (Catalina)
    Safari   14.0.3;  Firefox 89.0
    PHP 7.4 FastCGI

    Alter-Drukarsh connections... 3.3.8 <private>
    The Royals 3.3.8<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.8 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #5433

    The admin > media page had page full of this error.
    Deprecated: iconv_set_encoding(): Use of iconv.internal_encoding is deprecated in /home/user/alterfamily.woodengems.com/xxx/library/Zend/Locale/Format.php on line 313 (each repeat of error shows different line number

    I just checked the code and I can confirm that the term “iconv.internal_encoding” doesn’t exist anywhere in the 3.1.1 code.

    So your upload has failed again.

    I also checked, and it is FileZilla that regularly causes upload failures, and equally often doesn’t provide any feedback to tell you it failed.

    If you would like me to do the upload for you just send access details.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #5434

    Looking further (and before you try another upload) there is another possible / likely cause.

    the Zend library has code that checks the PHP version number.

    It does apply “iconv.internal_encoding” IF it finds that php is earlier than version 5.6.0.

    So double check that your A-D site IS still using 5.6.

    If it is, compare the contents of the file /library/Zend/Locale/Format.php as it exists on your server and as it exists in the kiwitrees 3.1.1 package before uploading. Go to the end of the file and compare the last few lines (from 1300 onwards.

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #5435

    Gee, missed updating PHP as well. It was 5.5. Your download page may remind users but I’m using the same download from Royals so wasn’t at your site. Realized version when I looked at my signature in this forum, which I just updated too.

    Changed to 5.6 and meantime am deleting files. Will upload with Transmit.

    -----
    [updated: 11 Jun 2021]
    MacOS: 10.15.7  (Catalina)
    Safari   14.0.3;  Firefox 89.0
    PHP 7.4 FastCGI

    Alter-Drukarsh connections... 3.3.8 <private>
    The Royals 3.3.8<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.8 <royals.rbcsolutions.ca/index.php?ged=rebbes>

  • #5436

    my site is alive.

    -----
    [updated: 11 Jun 2021]
    MacOS: 10.15.7  (Catalina)
    Safari   14.0.3;  Firefox 89.0
    PHP 7.4 FastCGI

    Alter-Drukarsh connections... 3.3.8 <private>
    The Royals 3.3.8<royals.rbcsolutions.ca
    >
    The Gerrer Rebbes 3.3.8 <royals.rbcsolutions.ca/index.php?ged=rebbes>

Viewing 10 posts - 1 through 10 (of 12 total)
  • The topic ‘Invalid JSON’ is closed to new replies.