Viewing 5 posts - 1 through 5 (of 5 total)
Author
Posts
  • #14103

    Hi Nigel,

    Trying to install 3.3.10 on a new cPanel webhost. Installing in a subdomain (tree.mydomain.com), php 7.4.28, Lightspeed webserver. I get through setup (phpMyAdmin browse of database looks good) but last step (login) throws the following errors. Would very much appreciate your help. Thanks Nigel

    Phred

    P.S. Beautiful day here in Tassie

    ……………….

    in function setOptions

    2 called from line 442 of file Session.php in function start  3 called from line 417 of file session.php in function require 4 called from line 25 of file login.php

    ERROR 2: ini_set() has been disabled for security reasons  0 Error occurred on in function ini_set [..]

    ………..

    Login request

    ………..

    ERROR 2: ini_set() has been disabled for security reasons
    0 Error occurred on in function ini_set
    1 called from line 1339 of file Format.php in function _setEncoding
    2 called from line 313 of file Format.php in function toNumber
    3 called from line 297 of file I18N.php in function number
    4 called from line 241 of file Page.php in function pageFooter
    5 called from line 51 of file Page.php in function __destruct
    6 called from

    [..]

  • #14104

    Disabling ini_set() is not uncommon on some shared servers, but not truly necessary in kiwitrees. It is used in various places to enable admins (only) to adjust things like php memory and time-out settings among others.

    I believe you should be able to enable it in cPanel either through its gui, or in the php.ini file on the server.

     

     

    Nigel
    My personal kiwitrees site is www.our-families.info
  • #14105

    Was afraid of that. I don’t have server root access. Had a good look around in WHM and cPanel doesn’t look like I can enable ini_set(). I will raise a support request with the webhost and see what they have to offer.

    Thanks

  • #14106

    Sorted.

    Information for others – as a place to look (your hosting account may differ of course):

    I found in cPanel PHP -> Select version and then under version what plugins to enable. Then Under “Options” found “disable functions”.  Removed ini_set from disabled functions list.

    Cheers

  • #14117

    Thanks for the tip. I’ve added it as an FAQ on the support area:

    https://www.kiwitrees.net/kb/faqs/

    Nigel
    My personal kiwitrees site is www.our-families.info
Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.