Author
Reply
  • #9802

    Just woke up to a message from the hosting service. Overnight they have found the reason for all the warning messages. As you surmised, Nigel, it was nothing to do with kiwitrees or my front-end modules, but to their implementation of PHP, but I’ll summarise here in case it’s of interest/help to others. Seemingly they use PHP from two different sources:
    ea-php (from cpanel) and alt-php (from cloudlinux)
    For reasons best known to them, they had set my account to use alt-php and in investigating my issue last night they have dicovered that:

    … when you use alt-php there are missing modules. This is some issue with the alt-php package, which we will work with the vendor to fix …

    Now they have set the account to use ea-php5.6 and the error messages have stopped. They go on to say:

    We are working to get ea-php70 , ea-php71,e ea-php72 . Once that is available (within a couple of hours ) , you can try using these versions of php on your website.

    So I shall try moving up to ea-php7.1 as soon as they have it available. Then I can forget about this diversion and get back to pursuing the original problem!

    Ron in France
    Website: https://clan-davies.kiwitrees.net/
    kiwitrees 3.3.9; PHP 7.3.5