• #7946

    How did you determine they were clippings cart files? If you are correct they would have been named clippings.ged, clippings(1).ged, clippings(2).ged etc…. or possibly .zip instead of .ged.

    They were certainly all clippings xxxx.ged and . zip – I remember that – and that they were very large files – the last few were all about 290MB. And I think this is the clue. I have a feeling that when a certain size is reached and some size parameter somewhere is exceeded the download cannot be completed and the files remain on the server in the data directory. I have just tested the theory by selecting my two most distant ancestors and requesting all their descendants PLUS all the media items associated with them. Clicked Download – seemed to be working for a long time but nothing arrived on my PC – checked the server and there in the data directory were two clippings files – a 5.9MB .ged file and a 56.04MB .zip file. I repeated the exercise WITHOUT requesting zip file of all associated media items and the download was performed OK and nothing remained in the data directory.
    Tried various combinations. When the file size is sufficiently small that the download commences, tried selecting cancel on the download reference tab that appears at the bottom of the screen. Download was cancelled mid-flight but nothing in data directory. Suggests to me that it is only when the cause of the download failure is either within kiwitrees or server software that the files end up in the data directory and that external causes do not have this result.
    I have tried several times to repeat the creation of files in the data directory but have failed – there has been neither a successful download nor a termination with files in the data directory – the system has simply hung.
    Will do some further testing later and report back. For the moment I must leave it as I am late for an appointment.

    Ron in France Website: kiwitrees 3.3.11; PHP 8.0.14