• #5462

    OK, that helps.

    Your MySQL has a time-out setting that is too low for the delete operation. There are a number of possible solutions:

    1 – Try referring this to your web host and ask if they can increase the mysql lock wait timeout. But I suspect the answer will be no.

    2 – The problem probably happens because your site_access table is grown too large. So delete some entries manually from the database.

    I suggest you try 1. first as it is the safest solution. If you delete the wrong rows you will lock yourself out of the whole site! Perhaps your web host will increase it just temporarily so you can then use the kiwitrees delete to correctly remove entries. (This is something that should be done every few months).

    If you must try 2. then take care.

    1. The table is xxx_site_access_rules
    2. ONLY delete rows that have the setting ‘rule’ = ‘unknown’. You can delete as many of these as you want.
    3. Do NOT delete any other rows.
    My personal kiwitrees site is